2 min de lectura

Cuando lo que deseamos es instalar una versión mas vieja a la que tenemos actualmente en nuestro sistema, se le llama “Downgrade” y ahora explicaremos como hacer eso en Ubuntu utilizando los repositorios sin tener que descargar los binarios y compilar nuestro paquete.

downgrad-php54

Paso 1: Quitar la versión PHP 5.4

Lo primero que debemos hacer es quitar el paquete de php5 que tengamos actualizado, lo cual debería basta con un apt-get remove php5, pero como queremos quitarlo por completo te recomiendo hacerlo de la siguiente manera

Paso 2: Instalar PHP 5.3

Ahora comenzaremos a instalar el php5.3 desde los repositorios, pero nota que utilizamos precisamente la versión exacta

Si además requieres paquetes extras, como gd, mysql, etc, entonces instálalos de la misma manera

 Paso 3: Asegurarnos de no actualizar a PHP 5.4

Debemos ahora asegurarnos que Ubuntu no actualizará nuestros paquetes de PHP y con ello instale de nuevo la versión actual de los repositorios

 

Notas: En la instalación el paquete puede cambiar dependiendo tu instalación de Ubuntu, de modo que en lugar de ser un 5.3.10-1ubuntu3.4 podría ser 5.3.10-13ubuntu3.6 o similar…
¿Te gustó este artículo?

Si te gustó este artículo, te ha servido o aprendiste algo nuevo; compártelo en tus redes sociales o invítame un cafe.

Líder técnico en equipos de desarrollo de software. Profesor de Desarrollo Web en la Universidad de Guadalajara. Emprendedora. Fundadora y CTO de CORB.mx. Ponente y tallerista. Colaboradora en proyectos de software libre y Open Source. Comprometida con la comunidad y la industria de la tecnología. Enfocada en el empoderamiento de las mujeres.

12 COMENTARIOS

  1. Estimada eso funciona tambien con Ubuntu4.7?? porque tengo un ubuntu 14.04 y quiero saber si funciona con eso o existe otra forma de instalar el PHP 5.3 en ubuntu 14.04?.

    Te agradeceria tu respuesta inmediata.

    Saludos

    • Que tal Hector,

      No lo he intentado en otras versiones, pero te recomiendo que primero revises si el paquete esta disponible, es decir, en lugar de ser un 5.3.10-1ubuntu3.4 podría ser 5.3.10-13ubuntu3.6 o similar…

  2. porque eh instalado el php5.5 y lo desinstale como indicaste pero al momento de instalar la version PHP 5.3 y cambie la version ubuntu a lo que tengo que es Ubuntu4.7 no funciona por que no encuentra el paquete de instalacion

    • Efectivamente, esta entrada es muy vieja, era para cuando se tenía en los paquetes de Ubuntu.
      Aún asi te recomiendo que primero sigas la nota para utilizar el nombre correcto del paquete con todo y tu versión de ubuntu, ejemplo: en lugar de ser un 5.3.10-1ubuntu3.4 podría ser 5.3.10-13ubuntu3.6 o similar…

Deja tus comentarios

This site uses Akismet to reduce spam. Learn how your comment data is processed.